Forums  
[line_separator]
  [Search] Search   [Recent Topics] Recent Topics   [Hottest Topics] Hottest Topics   [Members]  Member Listing   [Groups] Back to forum index 
Screen dims - more annoying than fatal  XML
Post Reply Forum Index » Possible Bugs
Author Message
Jassieteacake


Joined: 06/10/10 06:57 AM
Messages: 220
Offline

I found the solution. It no longer dims if you have the screen in a non-maxed out windown; have your sims in a smaller display window.

I found that by doing this, it no longer dims and I can alt-tab as much as I like. Does this work for anyone else?
Profile
BluebellFlora


Joined: 06/02/09 07:49 AM
Messages: 3867
Location:Los Santos

Unfortunately it doesn't work for me, but thank you anyway Jassie


15"MBP, 2.6Ghz QC i7, NVIDIA 650M 1Gb, 16Gb RAM, OS 10.9
Profile
Amykara


Joined: 04/15/10 03:59 PM
Messages: 1241
Location:Moonlight Falls
Offline

Mine dims when it goes into hibernation (When I go off some where and leave it on)

"Negativity isn't the way to go, smile more, eat some chocolate" - Ed Sheeran
Profile
jodiferous


Joined: 06/03/09 09:59 PM
Messages: 16
Offline

This happens to me as well. I am also on a Mac. As soon as the game launches, it goes dim. And stays that way. It just started today, when I updated to 1.33 and installed Showtime.

Going out to windows mode, activating finder doesn't even help. My screen will stay dim until I quit the game.

Profile
nakiBex


Joined: 06/05/09 10:00 AM
Messages: 153
Offline

I am on a windows machine and was getting this problem. I found this post which solved it for me. It was an HP process causing a conflict. I'm not sure if this will be the same with macs:

http://forum.thesims3.com/jforum/posts/list/15/346846.page#7486
150
Profile
liars_paradox


Joined: 11/18/11 04:59 AM
Messages: 145
Offline

GreenEyedMonster00 wrote:Okay, so I got a brand new laptop for Christmas cuz my old one is seriously sleeping with the fishies (or at least it should be). I installed all the Sims expansions I have and started playing. Everything was fine and dandy.

Then I alt-tabbed so that I could chat with my boyfriend on Skype. When I went back into Sims, the screen suddenly went dim. It's not a "problem" per se, but it's extremely annoying as it darkens the screen a little too much.

Yes, I am aware that to ultimately "fix" the problem, I can just NOT alt-tab. But I am OCD and very stubborn. Therefore, there has to be another solution that isn't so stupid.

Oh. And it doesn't dim at all when it's in windowed mode, but I can't stand playing it like that. And the screen doesn't dim on any of my other games when I alt-tab, so I don't think it's the laptop.


Awesome, I'm not the only person on the planet with this problem. I am so happy that you posted this thread.

This message was edited 1 time. Last update was at 05/11/12 11:55 PM

Profile
liars_paradox


Joined: 11/18/11 04:59 AM
Messages: 145
Offline

nakiBex wrote:I am on a windows machine and was getting this problem. I found this post which solved it for me. It was an HP process causing a conflict. I'm not sure if this will be the same with macs:

http://forum.thesims3.com/jforum/posts/list/15/346846.page#7486
150


Thanks, that fixed my problem! ^_^ I have an HP Pavilion dv7-6c95dx, btw.
Profile
IvoryButterfly


Joined: 06/17/09 06:53 AM
Messages: 1017
Location: No idea... you tell me then we'll both know!
Offline

SO this will work on a HP Dv6 Windows 7 laptop as well?

I'm just a little worried about doing anything to my files cause use my computer for work and can't afford to have it go awall on me

Profile
GlennGnerd


Joined: 10/07/11 04:25 AM
Messages: 228
Offline

I'm using a 2011 P-series Toshiba laptop, and the fix provided also solved my dimming issue - also disabled it in msconfig. I looked the problem up myself, but found that many users hadn't a clue.

No more having to restart the game to enjoy it in full screen.

Thank you

This message was edited 1 time. Last update was at 06/16/12 12:10 AM

Profile
GreenCats


Joined: 09/26/10 11:26 PM
Messages: 6926
Location:Lost in Misc Decor

We were discussing this a week or so ago, and quite a few people (including me) posted to say they had the same problem. I don't think anyone had a fix though - sorry

Profile
GreenCats


Joined: 09/26/10 11:26 PM
Messages: 6926
Location:Lost in Misc Decor

nakiBex wrote:I am on a windows machine and was getting this problem. I found this post which solved it for me. It was an HP process causing a conflict. I'm not sure if this will be the same with macs:

http://forum.thesims3.com/jforum/posts/list/15/346846.page#7486
150


Thanks for posting this. I will definitely try it out next time i have the games installed.

Profile
galaxy87


Joined: 07/13/10 12:20 PM
Messages: 2
Offline

I have this problem aswell, but my screen is dimmed at all times. When i Alt Tab it goes normal color for like five seconds, then it dims again. GRrr
Profile
KairiSims3


Joined: 10/21/11 11:30 PM
Messages: 31
Offline

For those of you too lazy to click the link the solution post was

Go into Task Manager, then the tab Processes, and check if you have a process called "igfxpers.exe", which will probaly have the desciption "persistence module". If you do, and it is listed under YOUR USERNAME on the computer, close it. DO NOT close it if it is listed under something else, for instance SYSTEM, Network Service or Local service - that could possibly harm your computer. Closing this process and then starting the game fixed the issue for me.


Profile
EmLouiseDarling


Joined: 06/03/13 04:35 PM
Messages: 1
Offline

The screen dimming happens to me also when I minimize the game and maximize it again or when my computer goes on sleep mode. I restart it to make it bright again. This never used to happen before but it started after I installed a few more expansion packs. I hate it so much! I have checked the game's display settings as well as the laptop's display settings and the brightness is all the way up with no dimming settings so it must be something to do with the game itself.

PLEASE can someone, anyone fix it?!
Profile
ceejay402


Joined: 02/28/11 10:32 PM
Messages: 12496

EmLouiseDarling wrote:The screen dimming happens to me also when I minimize the game and maximize it again or when my computer goes on sleep mode. I restart it to make it bright again. This never used to happen before but it started after I installed a few more expansion packs. I hate it so much! I have checked the game's display settings as well as the laptop's display settings and the brightness is all the way up with no dimming settings so it must be something to do with the game itself.

PLEASE can someone, anyone fix it?!


see if this helps

kiwi84 wrote:If you are playing the game on a laptop and find it goes dark if you had minimised it to the desktop for a moment at any stage for whatever reason, you can prevent this by doing the following before starting up the game again.

1. Right click on your Sims 3 desktop icon.
2. Pick the Compatibility menu folder.
3. On the five "Settings" boxes, tick the one marked "Disable desktop composition".
4. Click "Apply".


taken from this link - http://forum.thesims3.com/jforum/posts/list/634214.page


Profile
 
Post Reply Forum Index » Possible Bugs
Go to: