Forums  
[line_separator]
  [Search] Search   [Recent Topics] Recent Topics   [Hottest Topics] Hottest Topics   [Members]  Member Listing   [Groups] Back to forum index 
Sims 3 World Adventures fix for crashing etc - tried and tested - it works :)  XML
Forum Index » World Adventures
Author Message
helen1685


Joined: 07/22/09 10:27 AM
Messages: 1
Offline

Like many of you I have had problems with the sims crashing, freezing (error code 16 etc etc) since I installed world adventures. I found a fix about a month ago and have been playing the game problem free ever since...


You have to be running more than 2 gig of ram and have 64bit operating system.

Follow the below link, download the patch, extract it and run it. It will then prompt for the .exe location of the program you wish to patch. The .exe's I used is:

C:\Program Files (x86)\Electronic Arts\The Sims 3 World Adventures\Game\Bin\ts3ep01.exe

I don't recall applying this fix on the orginal sims3 .exe; just on the World Adventures .exe.

http://www.ntcore.com/4gb_patch.php
MD5: 1ADCA5A05497D3C2B73655966BC2EF74

My bf found this fix on a blog site which he can no longer find. The technical side of things is the above patch 'fixes' 64bit OSs' and their limit on virtual memory assignment which is limited to 2gb.

Hope this helps someone
Profile
VeeHexx


Joined: 12/16/09 08:00 PM
Messages: 1
Offline

(im helen's bf)

might be worth saying we hold no responsibility for things going wrong

im not entirely sure what the patch does, but it seems to moddify the .exe to change the virtual ram assignments (from what i've read, EA/Maxis limited to the 2gb limitation in the .exe. seems to be a simple ********** to change this limitation)

there is a known side effect of using this file: the game appears not to patch itself anymore. it claims an update is available, but it wont apply.

might be worth creating a copy of the original .exe, then patching with the above tool, and if you have issues you can simply delete the modified one and copy back the original .exe.
this would then enable the EA patcher to do it's magic, and once patched you can then re-apply the 4gb patch tool.


if you are unsure if your using a 64bit OS, then a quick look on C: drive will tell you:
If you have a folder called 'Program Files (x86)', then you are on a 64bit OS. if this folder does not exist, then your on a 32bit OS, and this patch does not affect you.
Profile
SimsFreak3774


Joined: 05/31/09 04:10 AM
Messages: 73
Offline

This does work but if you use just the patch then the patch makes an original backup file for you. This is located just below the modified one that you made with the patch.

To locate the backup file, go back to Local Disk-Program files(x86)-Electronic Arts-Sims3 World Adv.-Game-Bin TS3EPO1 and there should be a file with a blank page that says TS3EPOl-backup. Move this file to your desk top. You have to do a little "magic" to it by clicking on it and deleting the .backup part and the blank page will now turn into the original .exe file with the Sims icon. If you use the rename option, Windows says something like "are you sure you want to rename, this file may not work". Just say yes, the file will be ok.

I then went ahead and made two new folders on my desktop. One I named "Original Sims exe files" and the other "4GB patch files". As a "heads up" measure I check the website before I decide to play the game to see if an EA patch came out. If there is a patch out, I go to C: Program files (x86)-EA-Sims3 World Adv-Game-bin and find the modified .exe file then move it to my 4GB file I made and put the original file back in the bin. (Make sure you put in the bin) Reboot computer and go ahead and download the EA patch. Mine worked fine. After patching go back and replace the files. Remember, this is instructions for just the patch. You can download the CFF Explorer Suite which has different instructions to follow.

Also, the files I patched with 4GB patch are:

S3Launcher (.exe)
Sims3Launcher (.exe)
TS3EPOL (.exe)
TS3SPO1 (.exe)-High-End Loft

Remember that EA does not endorse this and download at your own discretion.

I also want to mention that this does not fix any in-game glitches. This patch allows your system to use more than 2GB of virtual memory if your system has 4GB or more.

This message was edited 2 times. Last update was at 06/25/10 10:58 PM

Profile
petalotus


Joined: 06/04/09 03:42 AM
Messages: 8
Offline

Hello, sorry to revive this post but I happened to stumble upon it trying to find help with Windows 7. I have Windows 7 64bit and tried this fix but it does not seem to work for me. I have patched every file just like SimsFreak3774 said and still not luck. My computer is still using only 2gb of memory. Thanks for any help in advance.

Specs:
Intel Core Duo 2.9ghz
Nvidia 7600
8gb of memory

Oh, this is a brand new computer so there is not much on here.
Profile
 
Forum Index » World Adventures
Go to: