Forums  
[line_separator]
  [Search] Search   [Recent Topics] Recent Topics   [Hottest Topics] Hottest Topics   [Members]  Member Listing   [Groups] Back to forum index 
Please Help Us Gurus! *Exception Raised Error and Game Crashes*  XML
Post Reply Forum Index » Mac Discussions
Author Message
kivby


Joined: 12/18/10 12:06 AM
Messages: 148
Location:South of the river
Offline

I have this problem too so I'm just bumping the thread and putting myself on the list for when a guru - finally - answers!


Profile
Pandacoffee


Joined: 02/13/11 02:27 AM
Messages: 748
Location:Boston, USA
Offline

It was behaving so well, then in the middle of my sim couple's it crashes and has the error I already downloaded the alternative patch, but my launcher refuses to open as well, just goes straight to the actual game.

Profile
Small_Fry94


Joined: 06/03/09 03:13 PM
Messages: 29
Offline

Thought I'd post here also--same error, the game shuts down whether I choose to debug it or not. When I reload the game, all relationships with other sims in the neighborhood are lost. Even if I save before this error shows up, it still effects my backed-up game (if that makes sense?). I noticed this also happens around the time I open the scrapbook, when trying to recover from the last crash and put the couples back together, and to see who was with who, as memories are still there but the actual relationship with that person is lost.
Profile
Dylanny


Joined: 04/20/10 05:47 PM
Messages: 369
Offline

I've had this problem as well.
I also got a million redundant notifications, disappearing Sims, sims forgetting actions, sims getting stuck in actions.

Finally, I reloaded the application from my Time Machine disk, choosing may 25th, before the patch and installing generations. (It took hours to copy over!)

Now I am playing Late NIght, not Generations, which clearly needs to be fixed for Mac.

(Everytime I start up it asks it if I want to install a patch... I say NO!)
Profile
mellysue


Joined: 06/10/09 06:33 PM
Messages: 224
Offline

Mine does this too... I uninstalled all of my games and installed them again, and right when things started looking good, out of the blue this crap happens again. Why oh why, does my *favorite* expansion pack have to be the biggest pain in my behind?!


Profile
stephybbyy


Joined: 09/20/10 11:40 PM
Messages: 14
Offline

this is happening to me too. i installed the patch last night and played for about half hour, just finished decorating, and the game crashed! i don't have generations, im running the same from late night. my game worked perfectly a couple days ago! grr ive spent so much money on these games, i would think that they would give us a gift of voucher or SOMETHING for all the crap thats been happening with the latest update!!!!
also, on another not, my game isn't letting me download anything from the exchange. Im not sure if thats related to the update or not. has anyone else been unable to download from exchange?
Profile
soliferi


Joined: 02/08/11 09:08 AM
Messages: 5
Offline

Exact same problem, but its only happened once for me so far when opening memories. and I have never had any cc and just completely re-installed everything because I hadn't played in a long time due to so many bugs from world adventures.

I only bought generations because it was something thats been missing since sims 2 that was important.
Profile
spartan1


Joined: 06/22/09 11:03 AM
Messages: 626

SimNow wrote:I got the same thing after saving and quitting, I don't know if I lost my game or not. I have all the Expansion packs, stuff packs and store content, but no mods or CC.


Add me to this list - I'm about to relaunch and check the damage, hoping I haven't lost anything.
Profile
MissChatterbox


Joined: 12/06/09 03:58 AM
Messages: 4224
Location:Gnarly, radical, on the block I'm magical.
Offline

Same problem here too, its only happened twice in about 9 hours, us it blimmin annoying. I get anxious to save constantly just so I dont loose any gameplay.

Profile
Galatea0


Joined: 02/08/10 09:33 AM
Messages: 157
Location:Australia
Offline

I don't have Generations yet, I just installed the latest patch for Outdoor Living Stuff. I have all EPs and SPs other than Generations.

I manually installed the latest basegame patch, so the launcher will run. But every time I try to open a game (whether saved or new), I get this message:

"unhandled page fault on read access to 0x000000000 at address 0x00ce2279, do you wish to debug?"

The game shuts down whether I say yes or no.

I've uninstalled and reinstalled every single EP and SP three times now, tried the game with and without CC. Nothing works.

My PC is also having problems after the latest patch, and the game won't run on that one either. I know it's not Mac-related, but I just thought I'd make you guys feel better by knowing it's not just the Macs that are unloved by EA patches right now.

Profile
melusinafire


Joined: 05/30/11 09:51 PM
Messages: 1
Offline

The same thing is happening with my game. I am scared to play again because I don't want to lose all my progress like I did last night. I exited CAS and was returning to my active family and I got the same error message/crash. EA needs to find a way to let customers know about large-scale game problems and their progress in finding fixes for them. Hopefully we wont have to endure this kind of situation with each new patch!
Profile
lillyloopin13


Joined: 06/02/09 08:01 PM
Messages: 20
Offline

I'm having the same issue too. I made a family, moved them from one house to another. After i finished renovating the house the stupid thing came up and friggen lost everything.

now when i play i'm saving every few minutes. this game is reeeally stressing me out. I can't even download & install ANY of my Store items without the game breaking.

Please, please please fix this!

Profile
Stinalina


Joined: 06/12/10 04:07 PM
Messages: 2386
Location:Somewhere over the rainbow
Offline

Im having the same issue... starting to wonder if any Mac players dont???

I followed the manual patch to restore the launcher, game seemed fine.
I have played two times since, but after a few hours of playing, game crash each time! The exact same way as OP, first in memory, next time in options!

So im basically re-playing the same events again and again - Im already tired of sending my teenager to the rabbit hole prom, and now i have to keep doing it because my game crash?! At least he makes prom king each time

I grabbed a screen shot as well, but i dont know how to post a pictures from my screen...?

And have anyone figures out how to type the @ to share the memories????

Useless game

...I really think its time for a lot of compensation EA!

Profile
fillupx333


Joined: 03/20/11 01:18 PM
Messages: 540
Location:=]
Offline

After 3 days of messing around with this issue, I was finally able to get my game to progress past the neighborhood loading screen. Since then I've only had the issue once, and that was when I was trying to move my Sim from one house to another via the phone option.

I now save constantly out of fear of losing everything.

I don't know what I did to get my game somewhat playable again as it seems to be random for everybody. However, I think the best piece of advice would be to MAKE SURE ALL OF YOUR MODS ARE UP TO DATE, if you use them that is. I read a post somewhere - lost the link, sorry - that said they can be a frequent culprit, especially core mods. Twallan seems to have most of his stuff updated, so if you haven't done so be sure to go get the new files.

Good luck, everyone. Let's hope EA continues to watch this forum and start providing us with the assistance we deserve.
Profile
EmEmEmma


Joined: 07/10/09 03:05 PM
Messages: 295
Offline

Same issue here! I hadn't saved in a while which was annoying! I was on my scrapbook when it happened.

Please help EA!

Blast me away.
Profile
 
Post Reply Forum Index » Mac Discussions
Go to: