Forums  
[line_separator]
  [Search] Search   [Recent Topics] Recent Topics   [Hottest Topics] Hottest Topics   [Members]  Member Listing   [Groups] Back to forum index 
How to find out why your computer is shutting down suddenly  XML
Post Reply Forum Index » Technical Discussions (EN)
Author Message
gutch


Joined: 06/18/09 01:43 PM
Messages: 4
Offline

It seems that lots of people have a big problem with The Sims 3: their computer shuts down suddenly after only playing for a short time. There are hundreds of people speculating about how to fix it but no-one has absolute answers.

However I've found out exactly why my computer is shutting down: My graphics card is overheating.

How do I know? Whenever I play The Sims 3 this gets recorded in the System log:
System shutdown due to graphics card overheating
So if you're getting these shutdowns, then you should check your logs too.

In my case, the log item was put in by the ATI driver atikmdag for my ATI Radeon HD 4870 on Windows Vista. Results might differ if your graphics card is different.

The good news is now that I absolutely know why my computer shuts down, I don't have to spend hours reinstalling and fiddling like some of the forum posts out there suggest. But the bad news is I don't know why only The Sims 3 causes overheating. My computer is very well ventilated. The graphics card has never overheated for other games. It has never overheated during hardware-assisted video encoding. But after recovering from a crash of The Sims 3 its core temperature is between 101 and 103 degrees celsius - about 10-20 degrees higher than normal... and of course high enough to boil water!

I suspect that a flaw in The Sims 3 code is causing the graphics card to work harder than it should. I can't prove that, but now that I have logs showing that The Sims 3 overheats, and only The Sims 3 overheats, it seems likely...

Profile
gutch


Joined: 06/18/09 01:43 PM
Messages: 4
Offline

How to check your event logs for overheating shutdowns

If you don't know how to check your logs in Windows, here's a quick guide:

  • Open the Control Panel
  • Navigate to System and Maintenance (if you use Windows Vista) or Performance and Maintenance (if you use Windows XP), then Administrative Tools, then Event Viewer.
  • In the Event Viewer, navigate to System events
  • Scroll through the list, clicking on events marked Error
  • If you see "System shutdown due to graphics card overheating" - or something similar - then your graphics card is overheating!


  • Hopefully confirming the problem will put your mind at ease. And even more hopefully it might encourage EA to fix The Sims 3 so it doesn't cause so many machines to overheat.
    Profile
    Birdbeast


    Joined: 06/18/09 06:25 AM
    Messages: 38
    Location:PA, USA
    Offline

    gutch wrote:I suspect that a flaw in The Sims 3 code is causing the graphics card to work harder than it should. I can't prove that, but now that I have logs showing that The Sims 3 overheats, and only The Sims 3 overheats, it seems likely...


    (edit: fixed double-spacing issue)

    I feel your pain. However, this is (most likely) not a flaw in the Sims 3 code, but actually a really terrible, awful design decision made by ATI/AMD for this series of cards, the implementation of that decision in the cards' BIOS, and a driver that pleasantly ignores the issue alongside.

    I have resolved this issue on my machine; if you can stomach my lengthy posts, read on for what I did.

    Here is a brief yet somewhat technical explanation of what is most likely happening (at least, it was happening for me on my machine):

    The Sims 3 is a DirectX 9 game -- while gorgeous compared to Sims 2, it's really not taking advantage of any bleeding-edge graphical techniques (which require DirectX 10). In fact, the Sims 3 is a very easy game for a card like the 4870 or 4870x2 to run.

    Which is exactly the problem. ATI has implemented a feature called PowerPlay on this line of cards that sounds logical on paper and, indeed, could have been implemented logically in code -- but they failed to do so, utterly.

    PowerPlay is designed to take a look at what your card is doing, and if it's not working hard, lower the graphics clock and memory frequencies to between 60-66% of stock frequencies (507/500 vs. the stock frequencies of 750/900). When the card does start to work hard, it increases those frequencies back up to their stock values (or the values you've set in the Catalyst Control Panel).

    PowerPlay surveys your card 1-3 times per second, and adjusts the frequencies accordingly.

    However, with games that don't work the graphics card too hard (or if there is some other condition in your system causing PowerPlay to think your card isn't working too hard -- which is what happened to me, but it's out of scope of this post), PowerPlay can get into a condition where it's CONSTANTLY adjusting your clock frequencies up and down and up and down and up and down -- again, up to 1-3 times per second.

    This frequent adjustment gets to be too much for the card and, yes, it overheats -- or the operating system throws up its hands in disgust and gives you a BSOD -- or you suffer a hard lockup, or a hard reboot... Anything can happen.

    So PowerPlay needs to be disabled. Fortunately, the one good thing about the Catalyst Control Center is that it supports the notion of "profiles," so we can create a profile to ENABLE powerplay (for when you're doing non-3D work with your computer) and another to DISABLE powerplay (for when you're playing 3D games). You simply must switch between them before and after you play.

    Here's how:

    (Note that I'm assuming your Windows drive is Drive C for the purpose of these instructions, AND that you are running the latest version of the ATI Catalyst Control Center and drivers -- v9.5 as of this writing)

    First, go to the following directory with Windows Explorer:

    C:\Documents and Settings\[Your user name]\Local Settings\Application Data\ATI\ACE

    If you are running Vista and you get "Access denied" messages trying to do that, go to this directory instead:
    C:\Users\[Your user name]\AppData\Local\ATI\ACE

    Now, open the Catalyst Control Center (right click on desktop, select it from the menu). Make sure you are looking at the ADVANCED view.

    Click the "ATI Overdrive" item in the list to the left.

    Make sure that Overdrive is unlocked (click the little key button if it's there).

    Now, click the arrow next to "Profiles" at the top of the window, and click "Profiles Manager."

    Type a name for your "PowerPlay ENABLED" profile (used when you are NOT playing games) in the drop down box. Make sure that in the Composition tab, the "the following settings" item is selected, and in the treeview list below, your graphics card is checked and beneath it, only the "ATI Overdrive" checkbox is checked.

    Click the Save button.

    Now, type the name for your "Powerplay DISABLED" (used for playing 3D games) profile in the drop down box, and click the Save button again. Leave this window open, but go back to Windows Explorer.

    There should now be a Profiles folder in the directory to which we browsed above. Open it. There should be two XML files here, each named exactly what you named your profiles.

    We will be leaving the "PowerPlay ENABLED" profile alone -- it's already set up exactly as it should be with all of the default settings for your card. You may wish to make a backup of this file, as you can always use it to restore your card to its default settings if you fear you've made a mistake.

    Open the "Powerplay DISABLED" (3D games) profile in Notepad. Make the following changes.

    NOTE: THE FOLLOWING SETTINGS ARE *ONLY* VALID FOR ATI RADEON HD 4870 GPUs. OTHER ATI GPUs REQUIRE OTHER SETTINGS. NVIDIA/INTEL GPUs ARE COMPLETELY OUT OF SCOPE OF THIS POST AND CANNOT BENEFIT. MAKE SURE TO READ YOUR GPU SPECIFICATIONS TO ENSURE THAT YOU ARE NOT SETTING YOUR FREQUENCIES HIGHER THAN YOUR GPU SUPPORTS.



    Save the file in Notepad and exit. Right-click the file, click Properties, and click the "Read-Only" checkbox at the bottom. Click OK.

    You may now close the Profile Manager window.

    From now on, whenever you want to play a 3D game, open the Catalyst Control Center, click the arrow next to Profiles at the top, and select your "Disable PowerPlay" profile (whatever you named it). Similarly, when you're finished, select the "Enable PowerPlay" profile.

    When you use the "Disable PowerPlay" (3D games) profile, you will see that the sliders change values, the temperature may increase slightly, the fan speed will increase (in fact you may hear your computer make a louder noise when you select the profile -- that's your video card fan spinning up to a higher rate), and the "GPU Clock" and "Memory Clock" values will increase. That's all perfectly normal. They will readjust to their former values when you re-enable PowerPlay with the "Enable PowerPlay" profile.

    That's it -- read on for some additional modifications you could make to the XML file:

    If your computer runs particularly hot (you can see the temperature of your graphics card processor(s) in the Catalyst Control Center's ATI Overdrive tab -- temperature, activity, and fan speed), you may wish to adjust the Fan Speed specified in the XML file. It's currently set to 50% -- you may adjust the value to anything from 20-100 (it's in the "FanSpeedPercentTarget_0" and "FanSpeedPercentTarget_1" sections of the XML file -- make sure to adjust BOTH numbers!).

    Typically, you'll want to keep your temperatures down under 80-85 C. ATI advertises that these cards are stable up to 100 C, but I would take that with a grain of salt.

    Also, the settings above for GPU and memory clocks are stock settings for the Radeon 4870 line. If you have the knowledge/cooling to overclock, you may feel free -- the numbers in the XML file are (for some reason) given in KHz (more likely it's a fixed-point data structure for MHz in which the final two digits appear after the decimal point, but the two are functionally equivalent). Just make sure that the Want_0 and Want_1 values are the same for all sections (that's the figures PowerPlay bounces between).

    Good luck!!
    -Birdbeast

    This message was edited 1 time. Last update was at 06/18/09 04:28 PM

    Profile
    Birdbeast


    Joined: 06/18/09 06:25 AM
    Messages: 38
    Location:PA, USA
    Offline

    Sigh. I don't know why my post got double-spaced. Sorry it's difficult to read. Maybe I'll create a new thread with those instructions so others with ATI card issues can see it in the main forum.

    (edit: I fixed it, sorry for extra post)

    This message was edited 1 time. Last update was at 06/18/09 04:28 PM


    My rig:
    Core2 Duo E8600 3.3GHz
    4GB DDR2 RAM
    Radeon HD 4870x2
    250GB Vista 64 HDD
    250GB XP x64 HDD
    1TB RAID5
    SB X-Fi
    Profile
    SimGuru_BGY_11


    Joined: 06/01/09 03:07 PM
    Messages: 7503
    Offline

    Hi there!

    Thanks for posting that. I've added this to my bookmarks, so if the issue comes up with other ATi users, we'll check via your solution.

    -Big Guy-

    Profile
    LadyGaia78


    Joined: 06/18/09 04:29 PM
    Messages: 5
    Offline

    I do not have an ATI card but have this same problem. I have a NVIDIA GeForce. I play other graphics heavy games (Sims 2, Oblivion, The Witcher, etc.) for hours on end on high settings without issue and my computer has never shut down by itself before or outside of playing Sims 3. In my case, I have no graphics card issues in the Admin logs and it seems to be rather random. I can play Sims 3 for hours with no problem at all. It's shut down after only 5 minutes of game play and it's shut down after an hour of game play, sometimes after a few hours. It shuts down while in build mode, it shuts down during play, and it's even shut down in neighborhood view while I'm doing nothing in particular. Twice it's shut down while I was away from the computer. There doesn't seem to be rhyme or reason, the logs tell me the shut down was unexpected. Well, duh. Unfortunately, none of the logs of the events tell me what the source of the problem is. The fan works fine, no overheating detected by feeling about the tower. 5 GB of RAM, all system requirements exceeded, my computer is about a year old.

    All that under consideration, I have to assume that this is Sims 3 related, not hardware related. Whether it's a design flaw who knows, but I do know this is the only software my computer seems to take issue with. I run 3D programs on this system daily, what's the beef?
    Profile
    Birdbeast


    Joined: 06/18/09 06:25 AM
    Messages: 38
    Location:PA, USA
    Offline

    LadyGaia78 wrote:I do not have an ATI card but have this same problem. I have a NVIDIA GeForce. I play other graphics heavy games (Sims 2, Oblivion, The Witcher, etc.) for hours on end on high settings without issue and my computer has never shut down by itself before or outside of playing Sims 3. In my case, I have no graphics card issues in the Admin logs and it seems to be rather random. I can play Sims 3 for hours with no problem at all. It's shut down after only 5 minutes of game play and it's shut down after an hour of game play, sometimes after a few hours. It shuts down while in build mode, it shuts down during play, and it's even shut down in neighborhood view while I'm doing nothing in particular. Twice it's shut down while I was away from the computer. There doesn't seem to be rhyme or reason, the logs tell me the shut down was unexpected. Well, duh. Unfortunately, none of the logs of the events tell me what the source of the problem is. The fan works fine, no overheating detected by feeling about the tower. 5 GB of RAM, all system requirements exceeded, my computer is about a year old.

    All that under consideration, I have to assume that this is Sims 3 related, not hardware related. Whether it's a design flaw who knows, but I do know this is the only software my computer seems to take issue with. I run 3D programs on this system daily, what's the beef?


    It does sound like either a RAM issue or a temperature issue. I have an 8800GTX in my other machine, but I don't play Sims 3 there -- I forget if the nVidia control panel gives you temperature readouts for the GPU, but if it does, you might want to check it out after playing the Sims 3 for ~5 minutes and quitting.

    Even better would be to run an application like GPU-Z (http://www.techpowerup.com/gpuz/), run the Sims 3 for about 5 minutes, quit, and look at the highest temperature your GPU reached. If that temperature is above around 85 C, you are going to want to increase airflow in your case and/or install additional fans and/or perhaps underclock some components.

    To test your RAM, you can download Memtest (http://www.memtest86.com/download.html) and write it to a floppy/burn it to a CD, and then boot from that floppy/CD and let it run through an entire test (takes an hour or two). If you have any errors listed during the test, you are either running your RAM at incorrect voltages/timings, your RAM is not fully supported by your motherboard, or you have bad RAM and it needs to be replaced.

    I understand that these issues only occur during Sims 3, but without a much wider sampling of games, one cannot conclude that it's *only* the Sims 3. Some games ask different features of the video card or use RAM in different ways, and will expose certain potential flaws better than other games.

    Good luck!
    -Birdbeast

    My rig:
    Core2 Duo E8600 3.3GHz
    4GB DDR2 RAM
    Radeon HD 4870x2
    250GB Vista 64 HDD
    250GB XP x64 HDD
    1TB RAID5
    SB X-Fi
    Profile
    LadyGaia78


    Joined: 06/18/09 04:29 PM
    Messages: 5
    Offline

    I appreciate the suggestions, but neither of those are the issue. I run Speedfan and monitor it during game play - the GPU and core temps never exceed 55-56 C. That is after hours of play time. I know my RAM is compatible and functioning properly, I installed it myself and monitor my hardware. Nevertheless, I booted from WMD (Windows memory diagnostic - or weapons of mass destruction, either way you look at it ) and there are no errors or other issues. My PSU is more than sufficient at 500w and also functioning as normal. I just cleaned out the tower not 2 days ago, I'm sure the inner workings are clean and functioning at their best. I perform regular maintenance (defrag, disc clean, virus scans). I play a purchased, registered copy of the game with no hacks/mods (only official EA CC at this point), disc inserted in the drive. While it would be simpler (probably not for me) for this to be something I could easily diagnose and upgrade/replace, I am not convinced it is a hardware issue at this time. Not that I would choose to spend the money on a hardware replacement for the sake of one game, when all other software runs properly.

    I'm open to suggestions - or a refund.
    Profile
    DarkAmaranth1966


    Joined: 06/17/09 10:54 PM
    Messages: 12705
    Location:In The Dark
    Offline

    I can play for hours, as can a few of my frieds but, not on Duo Core machines, it seems those have the shutdown issue under Sims 3. Odd I know and some are due to overheating, some are not but all seem to happen on duo core machines.

    Profile
    TacoT


    Joined: 06/12/09 02:18 AM
    Messages: 11
    Offline

    This exact issue happens to me occasionally, but i know exactly what causes it. I have a laptop and it only happens if I'm playing on certain surfaces (ie. blankets on the bed). It's just that my cooling fan doesn't work very well and the whole thing overheats. Didn't check the the temperature control specs before I bought it. Never mind.

    PS. to the person above, mine is a Dual Core as well.

    This message was edited 1 time. Last update was at 06/19/09 04:01 AM

    Profile
    iconchrono


    Joined: 06/17/09 11:06 PM
    Messages: 22
    Offline

    Here's a simple/easy/cheap fix to overheating issues.
    When I first built my newest iteration of my computer in my 15 year old computer case, I also experienced the random severe framerate drops and then eventually shutdowns.
    Tracked it down to heat.
    I knew that if I had a modern case with a million working fans, it would probably fix the problem.
    If I spent days messing with driver instructions that MIGHT also fix it.
    However, I took the easy route.
    Buy a big cheap fan from wal-mart or your preferred local store.
    Take the side cover off your computer case.
    Place fan in front of opening, turn to high.
    Problem has been solved for almost a year now!
    Profile
    gutch


    Joined: 06/18/09 01:43 PM
    Messages: 4
    Offline

    Birdbeast wrote:
    PowerPlay can get into a condition where it's CONSTANTLY adjusting your clock frequencies up and down and up and down and up and down -- again, up to 1-3 times per second.

    This frequent adjustment gets to be too much for the card and, yes, it overheats


    Thanks for the clear and detailed explanation of PowerPlay!

    I am disabling PowerPlay now and will see how I go. Interestingly my default profile XML file had a lower CoreVoltageTarget than shown in yours - I had 1203 instead of 1250. I'm sticking with the lower value, it seems safer.

    I'll report back in a day or two on whether I can play The Sims 3 for more than a few minutes at a time...
    Profile
    LadyGaia78


    Joined: 06/18/09 04:29 PM
    Messages: 5
    Offline

    Interesting about the dual core processors, I have one too. Although an incompatibility with the processor might suggest an overheating issue, which I've already demonstrated I don't have. This is good info for people to have, hopefully it will help out. OTH I have to question the logic of a game that burns up a system with a DCP, since they are popular on systems designed for gaming.
    Profile
    DaveUK


    Joined: 06/19/09 04:55 PM
    Messages: 2
    Offline

    Can someone please direct me in the way of buying additional fans for my laptop. I have a Dell XPS M1530 which fits the requirements.

    I can play the Sims 3 but in order to do so, I must make sure that the laptop is either precariously balanced on the side of a table or burning through my legs. I'm not an expert on this kind of thing but I believe it knocks itself off automatically when it reaches 90 degrees C.

    As it as shut down at least 10 times now, causing me to lose everything, I would like to purchase an external fan.

    Please help me with where I can find one. I don't want anything top of the range, just something to do the job!

    Thank you.
    Profile
    Battsknox


    Joined: 06/02/09 12:00 PM
    Messages: 1103
    Location:Smoky Mtns USA
    Offline

    Not trying to inject, but just a note I play on a dual core and I can leave the game running for days. My problem is a frame rate issue, triple time, etc.
    Just noting my dual core never crashes and overheating has never been an issue for me.
    I hope you guys figure it out, Good Luck!

    Profile
     
    Post Reply Forum Index » Technical Discussions (EN)
    Go to: