Forums  
[line_separator]
  [Search] Search   [Recent Topics] Recent Topics   [Hottest Topics] Hottest Topics   [Members]  Member Listing   [Groups] Back to forum index 
Generations Bug Thread - Please see compiled list on first page before posting.  XML
Forum Index » Generations
Author Message
Resender1


Joined: 05/29/09 02:29 PM
Messages: 172
Offline

pgamble1 wrote:
As a matter of fact, I was in China. This issue didn't occur for me till I installed Outdoor living and Generations.


I bought WA together with NL and fast lane and I got the exact same problem, since early NL.
Profile
tigerlily319


Joined: 06/29/09 07:35 PM
Messages: 526
Location:Nyanville
Offline

I don't know if this is a "glitch" per-say.. but it sure is annoying.. I decided to just let the game run and see what glitches popped up, and during the game my twin girls were playing with their IFs. But a little too much. I can understand playing/talking with their IFs, but when they start NOT SLEEPING or EATING, it gets a little crazy. The girls' IFs kept asking them to pillow fight and stuff so often that girls didn't have a chance to do anything and almost died of starvation and were constantly passing out from exhaustion. -.-

Profile
crinrict


Joined: 06/21/09 03:39 PM
Messages: 16941
Location:Switzerland

@belare:
- Game crashes go in the technical forum. Do you use any cc ?
- So you are missing sims after they come home from the vacation ? I added that.

@LRM09: see below.

@chattyaholic: Added your report to the issue. Try what Blysscia said. *skips rant*

@Blysscia: Thanks for posting

@ellerobbe: Thanks. Added that.

@perfectvelvet: Did you have NRaas mods in at the time it disappears ? It's not entirely impossible that this can be because of them. I'll check his forum if there were similar reports. I've added your name to the issue.

@Resender1: There's no sense in arguing over who got which bug when. It's there. Can we agree to that ?

@tigerlily319: I'll add

This message was edited 1 time. Last update was at 06/06/11 06:07 PM


Profile
crinrict


Joined: 06/21/09 03:39 PM
Messages: 16941
Location:Switzerland

List current up to here. If I missed your issue, please restate.

Something new that will be added to the rules soon:

Make sure you have no left overs from the old way of installing custom content.
- Uninstall Installer Helper Monkey. It's not uptodate anymore.
- Delete any d3dx9_31.dll in your sims directories. DO NOT DELETE THE ONE IN Windows\System32 OR YOUR WINDOWS MIGHT STOP WORKING



- Delete any resource.cfg from your expansions root folders. Only the ones in the Game\bin folders are valid and needed.
- Delete any mods folder from your expansions root folders. CC now goes in documents.



Profile
EIisabetta


Joined: 06/02/09 05:08 AM
Messages: 4782

Bump - Gurus, please sticky this thread.

Profile
Resender1


Joined: 05/29/09 02:29 PM
Messages: 172
Offline

crinrict wrote:
@Resender1: There's no sense in arguing over who got which bug when. It's there. Can we agree to that ?

Agreed, I hadn't seen your post when I posted.
I got 2 more issues that I had in a game I continued from Nl before the clean install.
And I haven't been able to retrace them since I haven't gotten to that part of game play yet.

Started in NL:
*Sims auto canceling reading books

Started in Generations
*Vampires not having learning bonuses during night.

Both these issues occurred before I did a clean install.

Think about creating an embassy lot, so my sims no longer would need to travel but can buy the WA stuff in the normal neighbourhood.

Also thinking about moving my current family from Bridgeport to a custom made neighbourhood, best to take the urns out of the family graveyard if I want to keep them.

Maybe a 3th issue
Sims seem to paint the same painting over and over again instead of varying.

This message was edited 2 times. Last update was at 06/06/11 08:40 PM

Profile
Haiden


Joined: 06/05/09 07:53 PM
Messages: 3125
Location:South Africa

Ok as far as I know the last thing I installed before Gen was OLS...which updated the base game.....since then there has been no new patch.

I installed Generations on Friday past, and it to updated the base game. The thing is I did not play after that as when I started my launcher it said there was a new patch...which I dld and installed.

First of all am I now on the correct game version:



When I click to play (since I patched) the launcher just stays non responsive, eventually I get this message:



Now what should I do?.....Should I unistall everything....then re-install each disk one by one, as this is my question....must I patch manually after each disk install OR install one disk after the other and patch after generations?

I installed the latest version of the EADM from the Generations disk....should I just remove it and install the one from the EA site?

I have read through this thread and I have had some of the issuse (gameplay wise) that others are having like:

items stuck in iventory
game locking up when switching households/moving a sim out
and level 10 sims not being able to fix simple things around the house...ect
Profile
orangeplumbob


Joined: 05/30/09 10:38 PM
Messages: 248
Location:San Diego
Offline

I have a solution for missing inventory items - especially photos in a camera. However it does require Master Controller:

Now when I originally loaded my Different Rain story, I discovered all of Parker's Relics and Nectar, some of his gems, and ALL of his pictures were gone from his inventory. Then I checked around the house, sure enough the photos in the Slideshow type frames were gone. However I noticed that the Frames that were the original photos were still on the walls. This got me thinking. I checked the chest Parker had in his room also and found it was nearly empty - pre Generations I had about 200 relics. GASP! So, I came up with a solution. One that worked for me:

First and FOREMOST MAKE SURE THE GAME DOESN'T PLAY A SINGLE SECOND UPON LOAD. Once the game plays even for a second or two the inventory glitches. This can be fixed by getting Twallan's Saver mod. My game doesn't play for any seconds upon loading, so I was able to fix the problem.

First click on sim - Master Controller - Basic - Sort Inventory
Click on any Frames, chests, bookcases, nectar storage, cameras (basically anything with Open Inventory on the intem) and use Master Controller to Sort Inventory.

Take out all inventory items from everything and place them somewhere in the lot. I used an empty room I had built just for staging.

Make sure everything is out of anything containing innovatory. I lost a lot of stuff originally - photos, gems, bars, nectar, relics. So I did this.

If a second of time doesn't go by it won't glitch. Now Save As a new name; ie Inventory Save, don't save it as the original file cause if something goes wrong you still have the backup.

Reload the Inventory save, check to make sure all items are still in game. Play a little bit to make sure nothing goes missing.

Now, put everything back. Pics in frames and cameras, relics in chests, books in bookcases, nectar in nectaries, ect. Put everything away and save as another new save.

Then close out and reopen that save. Play a bit of time and check your inventories. Everything should still be there. Save and then enjoy your game.

This message was edited 1 time. Last update was at 06/06/11 08:17 PM


Profile
ZeekSlider


Joined: 06/06/09 02:08 AM
Messages: 5305
Location:Isla Paradiso

Installed Generations. I now have Base 1.22 thru Gen 8.0. All game cache has been cleared prior to starting a new game in Sunset Valley.

- The "invisible building" bug is still around. It's the bug where you won't see a building/lot if you placed a pre-made or edited a lot. Building works fine and eventually shows up, but in Map View, it will always be invisible.

- Sims no longer are kicked out of Rabbit Holes when interaction is selected from Map View. Previous bug report must, therefore, be related to pre-existing games that the player has chosen to continue after patching/installing Generations.

- NPC Sims sometimes get stuck mid-stride in their walk animation and just stand there as their needs deplete. resetsim cheat seems to fix this.

At this point, I had the bright idea to create a Tester family. This was mostly because I wanted to isolate and control certain age groups without having to wait for my Sims to marry and have kids, etc. So I deleted the test game I had to construct a new one. Here's what I noticed when I restarted in Sunset Valley.

- It appears I no longer have the two clubs that come with the Lounging & Styling Late Night pre-order bonus. The rest of the items in the bundle do show up in CAS. Possible cause may be due to the fact that the clubs don't have names and just deleted them as a result. Stranger still is that attempting to reinstall the bundle without going through and uninstalling each individual item associated with it WILL reinstall the lost lots.

- Create-A-Sim no longer plays any music. AT ALL! Tried the Late Night walkaround, but it just won't play any music.

- Confirming the "can't pitch shift voices in CAS" bug I saw earlier in another thread. You can set the slider, and it will play back at that pitch, but you can't save your Sim with that pitched voice.

- Some hair will reset if they are missing a version of it for a particular outfit and/or age. (i.e. Some hairstyles that don't have a Sleep Outfit version will be replaced.) It's pretty much hit or miss, and this is with non-Store hair. Whatever hair the game replaces it with becomes the new hair style for the rest of the outfits on the Sims.

- Build/Buy Filters won't filter out DLC. The Filter believes that most of the DLC is actually part of the EP it was introduced in. (DLC chairs show up when you filter to see just the base game stuff; DLC Hot Tubs show up when you filter to just see Late Night stuff; etc.)

Like my post? Buy something off my wishlist as a thank you!
http://tinyurl.com/TS3Store-ZeekWishlist
Profile
CoffeeChick0


Joined: 06/20/09 08:23 PM
Messages: 2221
Offline

I read the first post and didn't see this mentioned.

(Note: I didn't read every single post in the thread.)

My game is up-to-date, I have one MOD, overwatch but this error was noticed prior to me re-installing overwatch, after loading Generations.

In CAS, under the little girl's shoes, the very first pair of sandals that came with Generations is showing up as invisible when worn. As you'll notice in the below picture you can only see the purple soles of the shoes.


Profile
crinrict


Joined: 06/21/09 03:39 PM
Messages: 16941
Location:Switzerland

@Resender1:
1) As soon as they start reading. Could you elaborate a little more ?
2) Probably a variation of the 'broken skill modifier' bug. Overwatch has a fix for that.

@Haiden: Try moving the following folders to your desktop:
- DCCache
- Library
- SavedSims
and restart the launcher. If it now opens, some cc did not get installed properly. Reinstall your stuff.

If that does not work, see if double clicking on ts3w.exe in your base game folder.

1) Try the suggestions on the first page
2) Any Pangu's Axe ?
3) I'll add

@orangeplumbob: Thank you for that.

@ZeekSlider: I'll go through your post again tomorrow and add accordingly.

@CoffeeChick0: Reading first page will do Did you update Overwatch ?
I'll try in my game and add.

This message was edited 1 time. Last update was at 06/06/11 09:10 PM


Profile
Resender1


Joined: 05/29/09 02:29 PM
Messages: 172
Offline

Yes I can
In this game when a sim had the read 'X' book interaction, either by autonomous command or by order of me. The sim would pick up the book, either from inventory or book shelf, open the book, close it immediately and put it in his/her inventory. Cancelling the action.

At first I thought I had broken something since I had 4 sims that each had written over 20 books.

As for the vampires I haven't converted any of my sims yet.

This message was edited 1 time. Last update was at 06/06/11 09:15 PM

Profile
bondedlead


Joined: 07/18/10 02:12 AM
Messages: 3
Offline

Hi. So last night I just had saved my sims game while there was a bad storm in fear that the power would go out. After I saved, the power went out. When I tried to play today the family I was playing did not even show their house or anything and was just like a blue outlined sketch. When I click on it to play, it says an error has occured please reinstall the application. I have several times, including my computer. And now I am wondering is there a fix for this? I looked online for other sources and they said to reinstall the game. 1) how do I do that? and 2) will that delete my family?

Thanks. I appreciate the help.
Profile
crinrict


Joined: 06/21/09 03:39 PM
Messages: 16941
Location:Switzerland

@Resender1: I'll add to the existing bugs list.

@bondedlead: Did the save finish before the power went out ? Were you able to close the game at all ? It's possible that something corrupted.

Did you run a chkdsk on your computer ?

Try if the game runs if you double-click on the tsw3.exe in the base game directory.

Here's what you need to backup to save your family: http://crinrict-help.blogspot.com/2011/03/faq-what-files-should
-i-backup.html


and instructions on reinstalling

http://crinrict-help.blogspot.com/2011/02/tutorial-how-to-resin
stall-game.html


Calling it a night early tonight. Hubby needs to get up very early. I'll check back tomorrow.

Keep bumping.

This message was edited 1 time. Last update was at 06/06/11 09:34 PM


Profile
wecantpickaname


Joined: 04/21/11 10:10 PM
Messages: 968
Location:USA

Surreal wrote:Just for the record, I'm running the patch, have all the EPs installed (except for Generations of course) and haven't found a problem yet. Removed all my mods prior to installing (and backed up saves, etc.). Prior to installing mods, I had the bad bed bug, but have not noticed it in game yet. And yes, the game does seem a bit smoother, and the story progression seems to be working a bit better. I could always learn the photo skill and see what happens if you want a tester.


This is what worked for me as well. I forgot that I had a couple of buydebug items on my lot so things went terribly wrong!

Profile
 
Forum Index » Generations
Go to: